提供zblog模板_zblog主题_wordpress模板的下载和定制

zblogphp升级到1.3后的各种报错汇总贴

天兴工作室 2014-06-20 教程 4583 0 评论


zblogphp于2014年6月14日升级到了1.3版本(Z-BlogPHP 1.3正式版发布了 命名为 Wonce Build 140614),结果很多朋友在升级到了zblogphp1.3后各种报错啊,论坛很多帖子都是反映升级后出现错误的。

天兴工作室升级到zblogphp1.3后也出现了错误,我来整理下我所遇到的问题和解决办法。

错误情况一:升级到发表文章直接出错打不开,错误信息“(2)E_WARNING :     Invalid argument supplied for foreach()”

原因:检查了半天发现是模板选择错误造成的,升级zblogphp1.3后不知道为什么文章选择的默认模板会变,匪夷所思。

解决办法:选择正确的模板,选择界面如下:

zblogphp升级到1.3后的各种报错汇总贴 教程 第1张    zblogphp升级到1.3后的各种报错汇总贴 教程 第2张

注意:index是首页模板,catalog或者index-list是列表页模板,single是内容页模板,发布文章请一定选择single模板,如果你出现这种错误,请仔细检查是不是有这种错误。

本文不定时更新,会收集各种zblogphp1.3升级所带来的错误和解决办法,推荐收藏,如果你遇到了错误,也欢迎在本文下评论区跟帖说出自己的错误类型。


没有找到解决你问题的教程?

您可以试着搜索一下或者直接在线提问。我们也提供收费技术支持,有需要可以在线联系我们。

在线提问 在线客服

取消回复欢迎 发表评论:

  • 请填写验证码
  • 最新文章
  • 热文排行
  • 最多评论
标签聚合

社交账号登录

将本文分享给你的朋友们