注册 登录 天兴工作室:提供zblog模板 emlog模板 dedecms模板的下载和仿站定制

zblogphp教程

zblogphp教程汇总

当前位置:网站首页 教程 zblogphp教程 正文

zblogphp升级到1.5的正确步骤

天兴工作室 2016-11-09 zblogphp教程 2847 ℃ 3 评论

zblogphp1.5出来有一段时间了,很多朋友也想把自己的网站升级到最新版的zblogphp1.5。但是zblog官方论坛一堆升级之后出错的,今天本文就来说下zblogphp1.5的正确升级步骤。

1、后台--主题管理--将主题切换到zblogphp的默认主题;

2、后台--插件管理--除开(应用中心)外关闭所有插件;

3、后台--应用中心--系统更新和校验--点击升级新版程序。

以上三个步骤做完,程序已经升级到最新的zblogphp1.5了,现在就是比较麻烦的部分了。

由于zblogphp1.4升级到zblogphp1.5的过程中官方修改了比较的系统函数之类的,所以一大把的zblogphp1.4下能正常的使用的主题和插件在zblogphp1.5环境下是会报错的。

所以呢,我们首先要看你网站正在使用的主题和插件有没有更新到支持1.5,如果没有,那么去联系你正在使用应用的应用作者们吧,反之应用都标注了支持最新的zblogphp1.5,那么就到后台--主题管理或者插件管理里面去启用相对应的应用即可。

最后的一点教程,是针对各位买了收费主题自己做了修改的,或者是专门定制主题的各位。(ps:仅限天兴工作室主题用户,其他主题用户请勿按照以下教程操作。)

天兴工作室的主题是可以直接升级到zblogphp1.5的,但是搜索界面会出错,解决步骤请往下看:

1、安装一个“主题编辑”插件,启用插件并打开插件;

2、插件界面打开“include.php”文件,在39行和81行(可能每个主题所在行数不一样),找到“$zbp->templates”修改为“$templates”保存提交即可; 

zblogphp升级到1.5的正确步骤 zblogphp1.5升级 zblogphp1.5错误 zblogphp1.5 zblogphp教程 第1张

赞 (2)

已有 3 位小伙伴发表了看法

摆渡

回应ta摆渡 (游客)

评论于 2016-11-24 14:32:08

哥,升级1.5后有个问题需要请教,也许你也没注意吧!以前1.4的时候相关文章正常,升级到1.5后,这相关文章这一块变成最新发布的文章了。目测你的这个主站也是这样。求解答!!
天兴工作室

回应ta天兴工作室 (管理员)

评论于 2016-11-24 14:44:55

zblogphp1.5的已知bug,据说会在1.5.1修复。。。
摆渡

回应ta摆渡 (游客)

评论于 2016-11-09 22:15:21

安装“主题编辑”插件之后,修改include.php文件之后,能否再把这个“主题编辑”插件关闭和删除?

欢迎 发表评论

服务项目

快速入口

常见问题

天兴工作室 | www.txcstx.cn

天兴工作室介绍天兴工作室承接:网站建设、zblog模板和dedecms模板定制、仿站(像素级仿站)、html单页面定制和修改、网站模板修改等服务;我们的办事准则:要么不答应、答应则一定做到

  • 交流群:ZBLOG交流群
  • 客户群:天兴工作室客户群
在线QQ 评论文章